Herzlich Willkommen im Forum! - Um alle Vorteile nutzen zu können, melde dich an oder registriere dich kostenlos.


  • 0 Bewertung(en) - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
[Projekt] CNC Fräse
Kann mir jemand sagen was ich hier falsch mache? Ich bekomme im Simulationsmodus von EdingCNC laufend die Meldung "Machine limit violation 27.0000" ? Ich wollte ein Programm schreiben um die Bohrungen auf der Platte anzubringen. Da möchte ich gerne Rampa-Muffen M8 einsetzen um Material zu befestigen.

   

Am Anfang habe ich die Originalgröße der Platte als Rohmaterialgröße eingegeben, ging nicht. Dann habe ich die Größe so reduziert das ich unterhalb der Verfahrwege meiner Fräse bleibe! Ging auch nicht, bin am verzweifeln.
PS könnte die Bohrungen ja auch von Hand machen, aber erstens wozu hat man die Fräse und zweitens möchte ich damit meine erste Aufgabe erledigen!
LG Hans
Mein Großprojekt: Werkstatt Mein 2. Hobby: Fotografie Meine Werkstatt: 73312 Geislingen
  Zitieren
Gefällt dir dieses Thema?
Teile es doch mit deinen Freunden!
Wie hast du den Bohrer in der Tooltabelle angelegt?

Edit: habs im GCode gesehen...

Kann es sein, das das Programm erstmal eine HomeProzedur abfahren will, Damit er weiß wo 0 auf allen achsen ist?

Nochwas: da steht in der Statusleiste Z 7
  Zitieren
 
Steht doch deutlich da, Verletzung der Limtvorgabe des zulässigen Z-Wertes von 7.0mm.
Mit dem G43 in Zeile 16 willst du einen Z-Wert von 15.0mm anfahren, was 8.0mm über dem Limit liegt.

Schau in die Einstellungen, welche Verfahrwege angegeben sind und wo die Limits festgelegt sind.

Im Übrigen, pass auf mit den Rampamuttern. Versenke sie ausreichend, nicht dass du dir gleich die Fräser ruinierst, wenn du in die Opfeplatte fährst.
Ich würde da nicht so viel Federlesen bei dem Provisorium machen. Fixiere deine Teststücke mit Spaxen in die Opferplatte und gut ist.
  Zitieren
 
(06.03.2019, 12:21)roerich_64_1 schrieb: Wie hast du den Bohrer in der Tooltabelle angelegt?

Edit: habs im GCode gesehen...

Kann es sein, das das Programm erstmal eine HomeProzedur abfahren will, Damit er weiß wo 0 auf allen achsen ist?

Nochwas: da steht in der Statusleiste Z 7
Hallo Walter, ich habe einmal alle Einstellungen abgelichtet:
                                       

Vielleicht kannst Du an Hand der Daten einen Fehler erkennen, aber bedenke ich befinde mich immer noch im Simulationsmodus! Mir fehlt ja immer noch eine kleine Steckplatine um die Verbindung von Eding CNC/USB herzustellen!
   
Hier noch die Daten bzw. Verfahrwege der BasicLine:
   

LG Hans

(06.03.2019, 12:46)Obelix schrieb: Steht doch deutlich da, Verletzung der Limtvorgabe des zulässigen Z-Wertes von 7.0mm.
Mit dem G43 in Zeile 16 willst du einen Z-Wert von 15.0mm anfahren, was 8.0mm über dem Limit liegt.

Schau in die Einstellungen, welche Verfahrwege angegeben sind und wo die Limits festgelegt sind.

Im Übrigen, pass auf mit den Rampamuttern. Versenke sie ausreichend, nicht dass du dir gleich die Fräser ruinierst, wenn du in die Opfeplatte fährst.
Ich würde da nicht so viel Federlesen  bei dem Provisorium machen. Fixiere deine Teststücke mit Spaxen in die Opferplatte und gut ist.
Hallo und Danke für die Rückmeldung! 
Wie und wo kann ich das ausbessern? Aber so das ich es verstehe?
UPS! Habe es hinbekommen, ich habe beim setzen des Nullpunktes der Z-Achse (Werkstück) einfach einen Wert von -10 eingegeben und dann erneut auf "Null" gedrückt und schon ist die Simulation gelaufen!
LG Hans
Mein Großprojekt: Werkstatt Mein 2. Hobby: Fotografie Meine Werkstatt: 73312 Geislingen
  Zitieren
 
(05.03.2019, 15:43)srambole schrieb: Habe aber noch ein anderes Problem, die 24V Lüfter für die Belüftung der Schublade kann ich doch nicht direkt an die Steuerung anschließen, da ich dort keine 24V Spannung habe. Jetzt habe ich mir zusätzlich ein 24V Netzteil in Miniformat für eine Hutschiene besorgt.

Bei mir haben die Motore generell ihr eigenes Netzteil. Wenn du Drehmonent willst, kommst du um höhere Spannungen (48V) nicht herum.
Die Nema23-Motore können Phasenströme über 4A/Phase vertragen. Das fordert dem Netzteil schon einiges ab.
Es ist also allemal besser und richtiger, der Peripherie nicht auch noch diesem Netzteil aufzubürden.
Es gibt da kleine Netzteile, die drei Spannungen zur Verfügung stellen, 5V, 12V und 24V. Damit kann man alle Bedürfnisse abdecken, ohne das 48V-Teil zu belasten.

Ein anderer Aspekt ist noch die Frage, ob du unbedingt die 24V-Lüfter mit 24V betreiben musst.
Die machen auch mit 12V ausreichend Wind. Deine Ohren werden es dir danken.

Gruß Volker
  Zitieren
 
(07.03.2019, 08:04)Obelix schrieb:
(05.03.2019, 15:43)srambole schrieb: Habe aber noch ein anderes Problem, die 24V Lüfter für die Belüftung der Schublade kann ich doch nicht direkt an die Steuerung anschließen, da ich dort keine 24V Spannung habe. Jetzt habe ich mir zusätzlich ein 24V Netzteil in Miniformat für eine Hutschiene besorgt.

Bei mir haben die Motore generell ihr eigenes Netzteil. Wenn du Drehmonent willst, kommst du um höhere Spannungen (48V) nicht herum.
Die Nema23-Motore können Phasenströme über 4A/Phase vertragen. Das fordert dem Netzteil schon einiges ab.
Es ist also allemal besser und richtiger, der Peripherie nicht auch noch diesem Netzteil aufzubürden.
Es gibt da kleine Netzteile, die drei Spannungen zur Verfügung stellen, 5V, 12V und 24V. Damit kann man alle Bedürfnisse abdecken, ohne das 48V-Teil zu belasten.

Ein anderer Aspekt ist noch die Frage, ob du unbedingt die 24V-Lüfter mit 24V betreiben musst.
Die machen auch mit 12V ausreichend Wind. Deine Ohren werden es dir danken.

Gruß Volker
Hallo Volker, ich habe bewusst nach 24V Lüfter geschaut, da ich im Vorfeld bei Sorotec angerufen habe und gefragt ob ich an der Steuerung Strom abgreifen kann für eben die 2 Lüfter. Da bekam ich die Antwort "Ja" aber 24V! Ergo habe ich 24V Lüfter bestellt! Was das eigene Netzteil für jede Endstufe anbelangt, so habe ich da, wegen fehlender Erfahrung, einfach Sorotec vertraut und mich beraten lassen! Ich denke die haben diese Komponenten schon öffters mit der Zusammenstellung verkauft!
LG Hans
Mein Großprojekt: Werkstatt Mein 2. Hobby: Fotografie Meine Werkstatt: 73312 Geislingen
  Zitieren
 
24V+24V = 48V Wink
  Zitieren
 
(07.03.2019, 08:41)srambole schrieb: Was das eigene Netzteil für jede Endstufe anbelangt, ......

Nein nein, bitte nicht falsch verstehen. Ich habe ein Netzteil für alle Endstufen gemeint, nicht ein sparates Netzteil für jeden Motor.

Du hast es ja mit einem separaten Netzteil gelöst, was ich gut finde.
Wie Walter schon schrieb, ergeben zwei 24V-Lüfter in Reihe auch 48V.
Insofern war die Aussage von sorotec nicht flasch.
  Zitieren
 
(07.03.2019, 10:13)Obelix schrieb:
(07.03.2019, 08:41)srambole schrieb: Was das eigene Netzteil für jede Endstufe anbelangt, ......

Nein nein, bitte nicht falsch verstehen. Ich habe ein Netzteil für alle Endstufen gemeint, nicht ein sparates Netzteil für jeden Motor.

Du hast es ja mit einem separaten Netzteil gelöst, was ich gut finde.
Wie Walter schon schrieb, ergeben zwei 24V-Lüfter in Reihe auch 48V.
Insofern war die Aussage von sorotec nicht flasch.
OK, jetzt habe ich es auch verstanden!  Thumbs Up
LG Hans
Mein Großprojekt: Werkstatt Mein 2. Hobby: Fotografie Meine Werkstatt: 73312 Geislingen
  Zitieren
 
Außerdem kannst auch so ein Modul dazwischenhängen um aus den 24V die 12V für deinen Lüfter zu machen.
3A können die zwar nicht, aber für die paar hundert Milliampere von deinem Lüfter reicht es aus.

Gruß Till
  Zitieren
 


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste