Herzlich Willkommen im Forum! - Um alle Vorteile nutzen zu können, melde dich an oder registriere dich kostenlos.


  • 0 Bewertung(en) - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
[Projekt] CNC Fräse
Das wesentliche ist getan Smile

Den Rest schaffst du auch noch Wink
  Zitieren
Gefällt dir dieses Thema?
Teile es doch mit deinen Freunden!
So erster Test mit Referenzfahrt und Werkzeuglängenvermessung erfolgreich bestanden!




Jetzt bleiben noch 2 Probleme, nachdem ich eine neue ini Datei erhalten habe, funktioniert soweit alles nur jetzt läuft meine Spindel nicht mehr an! Auch wenn ich ein Werkstück hochlade in die Software EdingCNC erscheint das Werkstück weit ausserhalb der Arbeitsfläche und ich bekomme immer eine Fehlermeldung!

Bild 1 zeigt die Arbeitsfläche in der Software ohne Referenzfahrt:
   

Bild 2 zeigt die Fahrwege nach der Referenzfahrt:
   

Bild 3 zeigt die Darstellung wenn ich ein Werkstück hochlade zum bearbeiten:
   

und Bild 4 zeigt die Fehlermeldung:
   

Aber ich denke das bekomme ich jetzt auch noch in den Griff, wenn jemand einen Rat weiß, nur her damit!

LG Hans
  Zitieren
 
Zwei Möglichkeiten:

a.) du übergibst die Zeichnung gleich mit ihrer Position im richtigen Quadranten mit der richtigen Z-Höhe, oder

b.) Deine Frässoftware kann die Zeichnung per ein zwei Mausklicks in den richtigen Quadranten verschieben und du setzt die Z-Höhe dort Wink
  Zitieren
 
Moin Hans,
schaumal nach den in der Software hinterlegten Verfahrwegen der Maschine.
Ich kenne Eding nicht, aber es müsste irgendwo in der Konfiguration abgefragt werden, wie groß die Arbeitswege der Maschine sind.
Die Fehlermeldung weist daraf hin, dass irgendwo ein Limit von 250mm hinterlegt ist.

Möglicherweise liegt auch der Ursprung in der Zeichnung außerhalb der Limits oder dein Maschinennullpunkt liegt irgendwo auf dem Bearbeitungsbereich und nicht in einer Ecke.

Mit den Nullpunkten ist es etwas verwirrend.
Maschinennullpunkt, Werkstücknullpunkt, Zeichnungsursprung, da kann man schnell durcheinander kommen.

Noch ein Hinweis:
Beim Anfahren des Sensors schaltest du sehr frühzeitig auf langsam. Das kostet viel zeit.
ich fahre bis auf 5mm schnell an den Sensor und dann erst mit langsamer Geschwindigkeit.
5mm reichen für den Verzögerungsweg völlig aus.

LG Volker
______________________________________________
sägen - messen - fluchen - nochmal machen
  Zitieren
 
(13.03.2019, 11:05)Obelix schrieb: Moin Hans,
schaumal nach den in der Software hinterlegten Verfahrwegen der Maschine.
Ich kenne Eding nicht, aber es müsste irgendwo in der Konfiguration abgefragt werden, wie groß die Arbeitswege der Maschine sind.
Die Fehlermeldung weist daraf hin, dass irgendwo ein Limit von 250mm hinterlegt ist.

Möglicherweise liegt auch der Ursprung in der Zeichnung außerhalb der Limits oder dein Maschinennullpunkt liegt irgendwo auf dem Bearbeitungsbereich und nicht in einer Ecke.

Mit den Nullpunkten ist es etwas verwirrend.
Maschinennullpunkt, Werkstücknullpunkt, Zeichnungsursprung, da kann man schnell durcheinander kommen.

Noch ein Hinweis:
Beim Anfahren des Sensors schaltest du sehr frühzeitig auf langsam. Das kostet viel zeit.
ich fahre bis auf 5mm schnell an den Sensor und dann erst mit langsamer Geschwindigkeit.
5mm reichen für den Verzögerungsweg völlig aus.

LG Volker
Hallo Volker,
ich stelle einmal hier die Einstellungen der Software EdingCNC rein, mit diesen Einstellungen funktioniert die Fräse einwandfrei bis auf das Problem das die Spindel nicht anläuft und es mir, wie geschrieben, das Werkstück immer außerhalb der Arbeitsfläche verschiebt:
   

Die Verfahrwege der Fräse sind hier:
   

LG Hans
  Zitieren
 
Was ich komisch finde ist, dass du alle Achsen in den negativen Bereich gelegt hast.
Das ist eigentlich nur für Z üblich, nicht für X und Y.
Bei der Konstruktion einer Zeichnung müsstest du in deinem Fall, den Ursprung oden rechts legen und im negativen X- und Y-Bereich zeichnen.
Sobald bei deiner Festlegung ein positiver Bereich angefahren werden soll, also >0, bist du außerhalb des Limits.

Beispiel:
G0 X15.0 Y15.0 --> außerhalb Limit
G0 X-15.0 Y-15.0 --> liegt in deinen Grenzen von 0 bis -630 für X und 0 bis -510 für Y
______________________________________________
sägen - messen - fluchen - nochmal machen
  Zitieren
 
Ergänzend zu Volker:

Könnte das Programm den negative Wert für Schritte Z intern irgendwie auswerten oder toleriert der das?

Hast du an den Treibern für Z eine andere Teilung eingestellt? 
Könnte sein, das Z später nicht maßhaltig ist...

   
  Zitieren
 
(13.03.2019, 17:04)roerich_64_1 schrieb: Ergänzend zu Volker:

Könnte das Programm den negative Wert für Schritte Z intern irgendwie auswerten oder toleriert der das?

Hast du an den Treibern für Z eine andere Teilung eingestellt? 
Könnte sein, das Z später nicht maßhaltig ist...

Wenn die Treiber 1/16 gejumpet sind, ist das schon richtig, während X+Y 10mm Steigung haben, hat Z 5mm.
Nur das Minus finde ich auch eigenartig. Geradeso als ob damit die Drehrichtung geändert wird.
Na ja, es macht halt jeder sein Ding, warum nicht auch EDING.

Gruß Volker
______________________________________________
sägen - messen - fluchen - nochmal machen
  Zitieren
 
(13.03.2019, 17:04)roerich_64_1 schrieb: Ergänzend zu Volker:

Könnte das Programm den negative Wert für Schritte Z intern irgendwie auswerten oder toleriert der das?

Hast du an den Treibern für Z eine andere Teilung eingestellt? 
Könnte sein, das Z später nicht maßhaltig ist...
Hallo Walter, 
die Z-Achse hat eine andere Spindel verbaut wie die x und y Achse, deswegen der andere Wert!
Hi Volker, genau richtig! Damit wird die Drehrichtung geändert! Aber ich habe die ini-Datei samt Macro schon an Sorotec gemailt und bekomme diese wieder per E-Mail so das die Software zu der Maschine angepasst ist!
Das mit der Spindel habe ich auch Dank telefonischer Hilfe vom Hauselektriker bei Sorotec hinbekommen, war ein Jumper auf der Interface Advance pro Platine falsch gesteckt und die Stromzufuhr vom Interface musste ich von einem extra 24V NT versorgen! Jetzt funzt die Spindel einwandfrei!
LG Hans
  Zitieren
 
Alles klar Hans,
du hast aber nichts zum negativen Arbeitsbereich deiner Maschine gesagt, ob dadurch dein Modell außerhalb liegt.

Gruß Volker
______________________________________________
sägen - messen - fluchen - nochmal machen
  Zitieren
 


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste